Back to overview
Downtime
Confirmo Pay is unavailable
May 28, 2026 at 12:36pm UTC
Affected services
Dashboard
API
Invoices
Payouts
Resolved
May 28, 2026 at 12:39pm UTC
All systems fully functional.
Affected services
Created
May 28, 2026 at 12:36pm UTC
Confirmo Pay is unavailable because of longer then expected infrastructure upgrade.
Affected services